cardboard: remove
Upstreamed and maintained.
This commit is contained in:
parent
747aae7774
commit
0b76292a1f
@ -1,62 +0,0 @@
|
|||||||
diff --git a/cardboard/meson.build b/cardboard/meson.build
|
|
||||||
index b236f71..a90f230 100644
|
|
||||||
--- a/cardboard/meson.build
|
|
||||||
+++ b/cardboard/meson.build
|
|
||||||
@@ -4,24 +4,15 @@ xkbcommon = dependency('xkbcommon')
|
|
||||||
xcb = dependency('xcb', required: get_option('xwayland'))
|
|
||||||
|
|
||||||
wlroots_version = '>=0.10.0'
|
|
||||||
-wlroots_proj = subproject(
|
|
||||||
+wlroots = dependency(
|
|
||||||
'wlroots',
|
|
||||||
- default_options: ['examples=false'],
|
|
||||||
required: true,
|
|
||||||
version: wlroots_version,
|
|
||||||
)
|
|
||||||
|
|
||||||
-wlroots = wlroots_proj.get_variable('wlroots')
|
|
||||||
-wlroots_conf = wlroots_proj.get_variable('conf_data')
|
|
||||||
-wlroots_has_xwayland = wlroots_conf.get('WLR_HAS_XWAYLAND') == 1
|
|
||||||
+have_xwayland = xcb.found()
|
|
||||||
|
|
||||||
-if get_option('xwayland').enabled() and not wlroots_has_xwayland
|
|
||||||
- error('Cannot enable Xwayland support in cardboard: wlroots has been built without Xwayland support')
|
|
||||||
-endif
|
|
||||||
-have_xwayland = xcb.found() and wlroots_has_xwayland
|
|
||||||
-
|
|
||||||
-expected_proj = subproject('expected', required: true)
|
|
||||||
-expected = expected_proj.get_variable('expected_dep')
|
|
||||||
+expected = dependency('tl-expected', required: true, method: 'cmake', modules: ['tl::expected'])
|
|
||||||
|
|
||||||
conf_data = configuration_data()
|
|
||||||
conf_data.set10('HAVE_XWAYLAND', have_xwayland)
|
|
||||||
diff --git a/cutter/meson.build b/cutter/meson.build
|
|
||||||
index f1260a4..1485f37 100644
|
|
||||||
--- a/cutter/meson.build
|
|
||||||
+++ b/cutter/meson.build
|
|
||||||
@@ -1,6 +1,5 @@
|
|
||||||
# SPDX-License-Identifier: GPL-3.0-only
|
|
||||||
-expected_proj = subproject('expected', required: true)
|
|
||||||
-expected = expected_proj.get_variable('expected_dep')
|
|
||||||
+expected = dependency('tl-expected', required: true, method: 'cmake', modules: ['tl::expected'])
|
|
||||||
|
|
||||||
executable(
|
|
||||||
'cutter',
|
|
||||||
diff --git a/libcardboard/meson.build b/libcardboard/meson.build
|
|
||||||
index 89698fe..3ac8115 100644
|
|
||||||
--- a/libcardboard/meson.build
|
|
||||||
+++ b/libcardboard/meson.build
|
|
||||||
@@ -1,11 +1,9 @@
|
|
||||||
# SPDX-License-Identifier: GPL-3.0-only
|
|
||||||
libcardboard_inc = include_directories('include')
|
|
||||||
|
|
||||||
-expected_proj = subproject('expected', required: true)
|
|
||||||
-expected = expected_proj.get_variable('expected_dep')
|
|
||||||
+expected = dependency('tl-expected', required: true, method: 'cmake', modules: ['tl::expected'])
|
|
||||||
|
|
||||||
-cereal_proj = subproject('cereal', required: true)
|
|
||||||
-cereal = cereal_proj.get_variable('cereal_dep')
|
|
||||||
+cereal = dependency('cereal', required: true, method: 'cmake')
|
|
||||||
|
|
||||||
sources = files(
|
|
||||||
'src/command_protocol.cpp',
|
|
@ -1,68 +0,0 @@
|
|||||||
{ stdenv
|
|
||||||
, lib
|
|
||||||
, fetchFromGitLab
|
|
||||||
, cereal
|
|
||||||
, cmake
|
|
||||||
, libGL
|
|
||||||
, libX11
|
|
||||||
, libinput
|
|
||||||
, libxkbcommon
|
|
||||||
, meson
|
|
||||||
, ninja
|
|
||||||
, pixman
|
|
||||||
, pkg-config
|
|
||||||
, tl-expected
|
|
||||||
, wayland
|
|
||||||
, wayland-protocols
|
|
||||||
, wlroots
|
|
||||||
}:
|
|
||||||
|
|
||||||
stdenv.mkDerivation rec {
|
|
||||||
pname = "cardboard";
|
|
||||||
version = "20210120.g7b15613";
|
|
||||||
|
|
||||||
src = fetchFromGitLab {
|
|
||||||
owner = "cardboardwm";
|
|
||||||
repo = "cardboard";
|
|
||||||
rev = "7b15613e6e1222a6a83d69a2e5da2810dfb45522";
|
|
||||||
sha256 = "044sb0lv1gcywpdncvlv7npxvbsqcc1mwpk0f6i73dinchdz7gmq";
|
|
||||||
};
|
|
||||||
|
|
||||||
patches = [
|
|
||||||
./0001-use-system-dependencies.patch
|
|
||||||
];
|
|
||||||
|
|
||||||
# CMake likes to own the configurePhase, but we only need it for dependency
|
|
||||||
# discovery. Remove it.
|
|
||||||
configurePhase = "mesonConfigurePhase";
|
|
||||||
|
|
||||||
nativeBuildInputs = [
|
|
||||||
cmake
|
|
||||||
meson
|
|
||||||
ninja
|
|
||||||
pkg-config
|
|
||||||
];
|
|
||||||
|
|
||||||
buildInputs = [
|
|
||||||
cereal
|
|
||||||
libGL
|
|
||||||
libX11
|
|
||||||
libinput
|
|
||||||
libxkbcommon
|
|
||||||
pixman
|
|
||||||
tl-expected
|
|
||||||
wayland
|
|
||||||
wayland-protocols
|
|
||||||
wlroots
|
|
||||||
];
|
|
||||||
|
|
||||||
passthru.providedSessions = [ "cardboard" ];
|
|
||||||
|
|
||||||
meta = with lib; {
|
|
||||||
description = "Scrollable tiling Wayland compositor designed with laptops in mind";
|
|
||||||
homepage = "https://gitlab.com/cardboardwm/cardboard";
|
|
||||||
license = licenses.gpl3;
|
|
||||||
platforms = wlroots.meta.platforms;
|
|
||||||
broken = true;
|
|
||||||
};
|
|
||||||
}
|
|
Loading…
Reference in New Issue
Block a user