diff --git a/modules/services/hardware/amdgpu-common.nix b/modules/services/hardware/amdgpu-common.nix
index 572d70a..ca4639d 100644
--- a/modules/services/hardware/amdgpu-common.nix
+++ b/modules/services/hardware/amdgpu-common.nix
@@ -7,7 +7,7 @@ with lib;
cards = mkOption {
type = types.listOf types.str;
default = [ "card0" ];
- example = literalExample ''[ "card0" ]'';
+ example = [ "card0" "card1" ];
description = ''
A list of cards to enable fan configuration for. The identifiers for
each device can be found in /sys/class/drm/ as card0, card1, etc.
diff --git a/modules/services/hardware/amdgpu-fan.nix b/modules/services/hardware/amdgpu-fan.nix
index 2e91ad9..4177362 100644
--- a/modules/services/hardware/amdgpu-fan.nix
+++ b/modules/services/hardware/amdgpu-fan.nix
@@ -33,14 +33,12 @@ in
[ 75 89 ]
[ 80 100 ]
];
- example = literalExample ''
- [
- [ 0 0 ]
- [ 40 30 ]
- [ 60 50 ]
- [ 80 100 ]
- ]
- '';
+ example = [
+ [ 0 0 ]
+ [ 40 30 ]
+ [ 60 50 ]
+ [ 80 100 ]
+ ];
description = ''
A list of temperature-fan speed pairs. The temperature is specified in
degrees celcius, and speed is specified in %.
diff --git a/modules/services/x11/dunst.nix b/modules/services/x11/dunst.nix
index 55e1428..1748e84 100644
--- a/modules/services/x11/dunst.nix
+++ b/modules/services/x11/dunst.nix
@@ -17,17 +17,14 @@ in
type = types.nullOr types.attrs;
default = null;
description = ''
- Configuration set alternative to
- configFile.
+ Configuration set alternative to configFile.
'';
- example = ''
- {
- global = {
- monitor = 0;
- follow = "none";
- };
+ example = {
+ global = {
+ monitor = 0;
+ follow = "none";
};
- '';
+ };
};
configFile = mkOption {